www.qialol.com
分享你的软件吧!

易语言结束并重启自身 纯源码

本文最后更新于2019-04-09 12:21:00 可能会因为没有更新而失效。如已失效或需要修正,请留言!

最近写插件,需要偶尔重启自身,但是遇到相同进程名,会不知道结束哪个进程,也不知道重启到哪个了,研究了下,换个思路就解决问题了。

子程序代码如下:

易语言结束并重启自身 第1张

.版本 2
.支持库 shell

.子程序 强制重启自身
.局部变量 dPath, 文本型
.局部变量 Path, 文本型
.局部变量 pid, 整数型

dPath = 取执行文件名 ()
Path = 取运行目录 () + “\” + dPath
pid = GetCurrentProcessId ()
写到文件 (取特定目录 (#临时文件目录) + “\restart.bat”, 到字节集 (“taskkill /f /pid ” + 到文本 (pid) + “ & start ” + Path))
运行 (取特定目录 (#临时文件目录) + “\restart.bat”, 假, #隐藏窗口)

相关DLL命令如下:
易语言结束并重启自身 第2张

.版本 2

.DLL命令 GetCurrentProcessId, 整数型, "kernel32.dll", "GetCurrentProcessId"

很简单就ok啦!

赞(0)
未经允许不得转载:个人技术分享 » 易语言结束并重启自身
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

我们还有这些好玩的地方……

QQ云挂机贴吧云挂机